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* System Requirements *

- OS : Windows NT 4.0 (SP>3), Windows, XP, 7,8 and Vista

- CPU : 200MHz

- Memory : 64MB RAM

- Hard Disk : 60 MB of free hard disk space

- Communication : Ethernet Port, Serial Port

- Online/ Offline Support

- Depending on the type of Network Adapter, Online mode can be supported or not.
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1. Automatic Scan

Users can have suitable programs that can be easily uploaded through Automatic Scan.

IO Guide Pro applies to Modbus protocol products. Automatic Scan has two options to choose, TCP/IP

and Serial. See below for more details.

How to run Automatic Scan

1. Click the below Toolbar.

Main Menu -> Online -> Click ‘Automatic Scan' (Hot key: Shift+S)
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1.1. TCP/IP

Step 1. Select TCP/IP in Select Option and ‘Click the SELECT LAN CARD’ button.

Select the lan card and click the scan button.
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Step 2. When the Communicating message box is created, Wait till Automatic Scanning is completed.

Step 3. When Automatic Scanning is successfully completed, You will see the pop-up message that says

‘Auto scan is successfully completed.'. Then, click the OK button.
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Step 4. Check if NA and I/O (already set up) is successfully scanned. Click the OK button.

Step 5. You can find the products that you have set up in Project Window
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1.2. Serial

Step 1. Select ‘Serial' in Select Option and enter the Port number. Click ‘Serial Communication Setting'

to set up Serial Communication.

Step 2. Set up according to the spec and Click the OK button. Click the Scan button
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Step 3. When Communicating message box is created, Wait till Automatic Scanning is completed.

Step 4. When Automatic Scanning is successfully completed, You will see the pop-up message that says

‘Auto scan is successfully completed.'. Then, click the OK button.
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Step 5. Check if NA and I/O (already set up) is successfully scanned. Click the OK button.

Step 6. You can find the products that you have set up in Project Window.
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2. Bootp Server

IO Guide pro supports for the Bootp Server of MODBUS TCP and Ether Net IP module.

The server has Automatic Setting and Manual Setting. See below for more details.

How to run Bootp Server

Main Menu -> Tools -> Click ‘Bootp Server’
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2.1. Automatic Setting

Step 1. Click ‘Start Bootp’ and turn on the product.

※ When you tick the box ‘Show CREVIS device only’, you will see only CREVIS ones on Request History.
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Step 2. Check MAC Address of products uploaded on Request History and double-click on the one.

Step 3. Select the Interface(LAD Card), enter IP Address and click the OK button.
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Step 4. When IP setting is successfully completed, Check IP Address set on Setup History and turn

Off/On the power.

Step 5. Turning Off/On the power and scan again, you will see the IP Address changed.
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2.2. Manual Setting

Step 1. Click ‘Add New Device'.



17 IOGuidePro User Manual

Copyright(C) CREVIS Co.,Ltd Support +82-31-899-4599 URL: www.crevis.co.kr

Step 2. Selecting the Mac Address, IP Address, Subnet Mask, Gateway and Interface(LAD Card), click the

OK button.

※ Mac Address can be found on MAC labels which is attached on products.
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Step 3. When IP setting is successfully completed, Check IP Address set on Setup History and turn

Off/On the power.

Step 4. Turning Off/On the power and scan again, you will see the IP Address changed.
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3. User Interface

IO Guide Pro consists of the five user interface and see below for more details.

Menu : General menu for IO Guide Pro

Project Window : Shows project name and product name and info.

Log Message Window : Shows Log about errors, operation info, communication info.

Main Window : Shows products group, in/output or parameter value and Address Map etc. Users can

set the important info on the actual operation.

NA & IO List Window : shows product family list and the spec of the product.
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3.1. Main Menu

Refer to the following tables for more details.

■ File

Menu Sub Menu Description

Project File New Create new project

Open Open the saved project

Close Close current project

Save Save as current project

Save as Save current project as new name

Documentation Project Make documentation as desired in the selected Project

Network Adapter Make documentation as the setting of selected NA

Inquiry Project Provides info. how many quantities used in the project

Selected Network

Adapter
Provides info. how many quantities used in the selected NA

Recent File - Displayed the latest activated project file

Exit - Close the program

■ Edit

Menu Sub Menu Description

Add Network Adapter Add network adapter to the selected project

Module Add IO module to the selected NA

Move up - Move up the selected IO module

Move down Move dwon the selected Project, NA and IO module

Delete - Delete the selected Project, NA and IO module
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Rename - Change the name of the selected IO module or NA

Properties -
Check properties information in the selected NA and IO

module

Check Validation Project Check setup error in the selected project

Network Adapter Check setup error in the selected NA

Reset to Factory

Default
-

Change parameter of NA and IO module into default.

which is subject to Project value and no change in Online

■ View

Menu Sub Menu Description

View Address Map - Displayed address map of the selected NA

NA & IO List - Choose to activate NA & IO list Window

Project Window - Choose to activate Project Window

Log Message - Choose to activate Log Message

Toolbar - Choose to activate Toolbar

Status Bar - Choose to activate Status Bar

■ Online

Menu Sub Menu Description

Automatic Scan -
Search NA which is connectable and upload seached NA and IO

information.

Compare with

Offline (NA)
-

Comparing Project NA in editing with Online NA at the point of

structure between NA and parameter information .

Download -
Download IO and Parameter Value modified in Project into

Online NA.

Upload -
Upload IO and Parameter Value of Online NA. At that time set

value of Project does not changed.
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Reset Parameter - Reset Parameter Value of Online NA or IO with Factory Default.

Copy to Project -
Change Project value into NA or IO value of Online NA or

Parameter Value.

Special

Commands(NA)
- Transfer Reboot or Reset Error result to Online NA.

Start Monitoring - Begin to monitor whole of NA in Project.

Stop Monitoring - Close to monitor whole of NA in Project.

■ Option

Menu Sub Menu Description

Configuration - Change parameter of IOGuidePro program

■ Tools

Menu Sub Menu Description

Bootp Server - Set IP Address of the product which supports Bootstrap Protocol

Protocol Messenger Modbus Low Level Communication in the selected protocol.

■ Help

Menu Sub Menu Description

IOGuidePro - Show manual of IOGuidePro

FnIO Technical Data - Show technical data of FnIO products

About IOGuidePro - Show version information of IOGuidePro.
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3.2. Toolbar

Refer to the following tables for more details.

■ [Standard] Toolbar

Icon Title Menu Description

New File -> Project File -> New Create new project

Open File -> Project File -> Open Open the saved project

Save File -> Project File -> Save Save current project

About Help -> About IOGuidePro Show version information of IOGuidePro

■ [Add] Toolbar

Icon Title Menu Description

Add Network

Adpater

Edit-> Add -> Network

Adapter
Add network adapter to the selected project

Add Module Edit -> Add-> Module Add IO module to the selected NA

■ [Modify] Toolbar

Icon Title Menu Description

Move Up Edit -> Move Up Move up the selected IO module

Move Down Edit -> Move Down Move down the selected IO module

Delete Edit -> Delete Delete the selected item
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■ [Online] Toolbar

Icon Title Menu Description

Automatic Scan Online -> Automatic Scan
Search NA which is connectable and upload searched NA

and IO information.

Compare with

Offline

Online -> Compare with

Offline

Comparing Project NA in editing with Online NA at the

point of structure between NA and parameter

information.

Download Online -> Download
Download IO and Parameter Value modified in Project

into Online NA.

Upload Online -> Upload
Upload IO and Parameter Value of Online NA. At that

time set value of Project does not changed.

Reset Paramter Online -> Reset Parameter
Reset Parameter Value of Online NA or IO with Factory

Default.

Copy to Project Online -> Copy to Project
Change Project value into NA or IO value of Online NA

or Parameter Value.

Start Monitoring Online -> Start Monitoring Begin to monitor whole of NA in Project.

Stop Monitoring Online -> Stop Monitoring Close to monitor whole of NA in Project.

■ [Validation] Toolbar

Icon Title Menu Description

Project Validation Edit -> Check Validation -> Project Check setup error in the selected project

NA Validation Edit -> Check Validation -> NA Check setup error in the selected NA

■ [Document] Toolbar

Icon Title Menu Description

Project

Documentation

File -> Documentation ->

Project

Make documentation as desired in the selected

project
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NA

Documentation
File -> Documentation ->NA Make documentation as the setting of selected NA

■ [Inquiry] Toolbar

Icon Title Menu Description

Project

Documentation

File -> Documentation ->

Project
Make documentation as desired in the selected project

NA

Documentation
File -> Documentation-> NA Make documentation as the setting of selected NA



26 IOGuidePro User Manual

Copyright(C) CREVIS Co.,Ltd Support +82-31-899-4599 URL: www.crevis.co.kr

3.3. Project Window

At Project Window, users can find the products and some info related to each project.

At Toolbar, users can set the suitable mode through three view modes.

Three View modes)

Three View modes are as follows:

Mode Description

User View Show the name registered by a user.

Product View Show the product name only.

Product, Desc View Show the product name, the main function and the brief spec.

3.3.1. User View

User View shows the name registered by a user as below.
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How to rename

Step 1. Select the product with right-clicking and click ‘Rename'. (Hot key: Ctrl+R)

Step 2. When Rename message box is created, enter the name in the New box.

Step 3. Clicking the OK button, the renamed one will be shown as below.
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3.3.2. Product View

Product View only shows the product name as below.

3.3.3. Product, Desc View

Product, Desc View shows the product name, main function, and brief spec as below.
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3.4. Log Message Window

Log Message Window has five tabs as below. Refer to the following table for more details.

Log Message Window Tab function)

Tab Description

All Show all of Log such as Error, General, Communication, etc.

Error Show Log about the error has occurred.

General Show Log about the general function. (Auto scan, Download, etc.)

Communication Show Log about communication.

Developer Show Log about technical support and cautions.
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3.5. Network Adapter & IO List Window

Clicking the product, you can see spec, diagram, LED status, etc. through IO Guide Pro Help file. See

below.
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4. Main Window

4.1. Crevis Homepage Tab
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4.2. Image Tab

At Image Tab, users can find the Description, Specification and pictures of products.

ex) Network Adapter: Description, Total Current, Total Size.

Network Adapter

I/O
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4.3. Process Image Tab

At Process Image Tab, the output value of real I/O can be set up through Project Value

and the input value can be found through Online Value.
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4.4. Parameter Tab

At Parameter Tab, users can check the parameter of corresponding I/Os and set up as well.
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4.5. Address Map Tab

Address Map Tab shows the Address info of I/O set-up.
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4.6. Comment Tab

Users can write anything at Comment Tab.
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5. Protocol Messenger

IO Guide pro supports for Protocol Messenger of MODBUS module.

Users can run the messenger through Modbus TCP and Modbus RTU. See below for more details.

How to run Modbus Protocol Messenger (Hot key : Shift+B)

Main Menu -> Tools -> Protocol Messenger -> Click ‘Modbus'
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5.1. Modbus TCP

Step 1. Select the Protocol with Modbus TCP and enter IP Address.
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Step 2. The following example: 0x1045 will be used for IP setting of Special Register of NA-9289.

Step 3. Register SET-UP(Read)

Set up the Function code with ‘03' and enter the Address, ‘1045'.

click the ‘Send' button, you will find the value ‘0000' on the Response box.

(0=BOOTP, 1=DHCP)
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Step 4. Register SET-UP(Write)

Set up the Function code with ‘16' and enter the Address, ‘1045'.

Entering ‘0001' in Send Data and click the ‘Send' button, you will find the value ‘0100' (shown in reverse

with Swap word set-up) on the Response box.

.
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5.2. Modbus RTU

Step 1. Select the Protocol with ‘Modbus RTU’, and set-up the COM Port.

Input the data as shown in the following on Serial Communication Setting and click the OK button.

※ Refer to the following Serial Configuration
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Step 2. Register SET-UP(Write)

Set up the Function code with ‘16' and enter the Address, ‘1045'.

Entering ‘0001' in Send Data and click the ‘Send' button, you will find the value ‘0100' (shown in reverse

with Swap word set-up) that you already set up in Register Write.

(0 = BOOTP, 1 = DHCP)
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Step 3. Register SET-UP(Read)

After turning Off/On the power in the above Register Write process, Set the Com Port and Serial

Communication again.

Set up the Function code with ‘03' and enter the Address, ‘1045'. When click the ‘Send' button, you will

find the value ‘0100' (shown in reverse with Swap word set-up) that you already set up in Register Write.

(0 = BOOTP, 1 = DHCP)
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6. Project Documentation

In IO Guide Pro, the Project information about product, q'ty, Address Map, Parameter, etc. can be

extracted into EXCEL and PDF.

Project Documentation (Hot key : Shift + P)

or Press the Shift key with ‘B'. (Hot key: Shift+B)

1. Click the below Toolbar.

2. Main Menu -> File -> Documentation -> ‘Click ‘Project'
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Project Documentation Sample)
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